$re = '/(?<!\d)\d(?!\d)/m';
$str = 'Klasse 1a 14/15
5/66
1/2/3
4. Klasse
Klasse 99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);