#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^jdbc:oracle:thin:((?P<username>[a-zA-Z0-9]{1,})([\/](?P<password>[a-zA-Z0-9]{1,})){0,1}){0,1}@(?P<ezdb_name>((\/\/){0,1}(?P<hostname>[a-zA-Z0-9\.\-]{1,})(\:(?P<port>\d+)){0,1})(\/(?P<service_name>[a-zA-Z\.\-0-9]{1,}(\:(?P<server_type>[a-zA-Z]{1,})){0,1}){0,1}(\/(?P<instance_name>[a-zA-Z0-9]{1,})){0,1}){0,1})$"
Local $sString = "jdbc:oracle:thin:@//hostname.example.ru:1521/database.example.ru" & @CRLF & _
"jdbc:oracle:thin:@sales-server" & @CRLF & _
"jdbc:oracle:thin:@sales-server:3456" & @CRLF & _
"jdbc:oracle:thin:@sales-server/sales" & @CRLF & _
"jdbc:oracle:thin:@sales-server:80/sales" & @CRLF & _
"jdbc:oracle:thin:@sales-server/sales:dedicated/inst1" & @CRLF & _
"jdbc:oracle:thin:@sales-server//inst1" & @CRLF & _
"jdbc:oracle:thin:@sales-server:1521/sales.us.acme.com" & @CRLF & _
"jdbc:oracle:thin:@//sales-server/sales.us.acme.com" & @CRLF & _
"jdbc:oracle:thin:@//sales-server.us.acme.com/sales.us.oracle.com" & @CRLF & _
"jdbc:oracle:thin:wat@//sales-server.us.acme.com/sales.us.oracle.com" & @CRLF & _
"jdbc:oracle:thin:wat/wat@//sales-server.us.acme.com/sales.us.oracle.com" & @CRLF & _
"jdbc:oracle:thin:wat/wat@//sales-server.us.acme.com/sales.us.oracle.com:dedicated/instance" & @CRLF & _
"jdbc:oracle:thin:wat/wat@//sales-server.us.acme.com//instance" & @CRLF & _
"jdbc:oracle:thin:@hostname:1521:DATABASE" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")