Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
^jdbc:oracle:thin:((?P<username>[a-zA-Z0-9]{1,})([\/](?P<password>[a-zA-Z0-9]{1,})){0,1}){0,1}@(?P<ezdb_name>((\/\/){0,1}(?P<hostname>[a-zA-Z0-9\.\-]{1,})(\:(?P<port>\d+)){0,1})(\/(?P<service_name>[a-zA-Z\.\-0-9]{1,}(\:(?P<server_type>[a-zA-Z]{1,})){0,1}){0,1}(\/(?P<instance_name>[a-zA-Z0-9]{1,})){0,1}){0,1})$
"
gm
Input 1
1
New
jdbc:oracle:thin:@//hostname.example.ru:1521/database.example.ru jdbc:oracle:thin:@sales-server jdbc:oracle:thin:@sales-server:3456 jdbc:oracle:thin:@sales-server/sales jdbc:oracle:thin:@sales-server:80/sales jdbc:oracle:thin:@sales-server/sales:dedicated/inst1 jdbc:oracle:thin:@sales-server//inst1 jdbc:oracle:thin:@sales-server:1521/sales.us.acme.com jdbc:oracle:thin:@//sales-server/sales.us.acme.com jdbc:oracle:thin:@//sales-server.us.acme.com/sales.us.oracle.com jdbc:oracle:thin:wat@//sales-server.us.acme.com/sales.us.oracle.com jdbc:oracle:thin:wat/wat@//sales-server.us.acme.com/sales.us.oracle.com jdbc:oracle:thin:wat/wat@//sales-server.us.acme.com/sales.us.oracle.com:dedicated/instance jdbc:oracle:thin:wat/wat@//sales-server.us.acme.com//instance jdbc:oracle:thin:@hostname:1521:DATABASE