const regex = /[^\s@#$%^&+=_]*[@#$%^&+=_]\S*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\s@#$%^&+=_]*[@#$%^&+=_]\\S*', 'gm')
const str = `abc 123 abc12def abc@dd44-@#\$\$%^&^*() abcdd44-*()
abc123abc12defabc@dd44-@#\$\$%^&^*()abcdd44-*()
abc 123 abc12def @abc@dd44-@#\$\$%^&^*() abcdd44-*()`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}