$re = '/((?<=\[)..:)|((?<=\[).)/';
$str = 'asdf[D4:asdf]';
$subst = ";";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;