package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([#@]?\w+|\pP+|\S)`)
var str = `This is a common Tweet #format where @mentions and.errors!!!!like this:-)))))might #appear⤠â¤â¤#ThisIsAHashtag!?!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}