using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\/(dp|product)\/ | .*page";
string substitution = @"";
string input = @"http://www.amazon.in/s/lp_6563520031_pg_2?rh=n%3A5866078031%2Cn%3A%215866079031%2Cn%3A6563520031&page=2s&ie=UTF8&qid=1446802571";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}