package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`|author`)
var str = `{{cite web|url=http://example.com|author=Ninguém}}
{{cite web|url=http://example.com|author=Alguém}}`
var substitution = "\|autor"
fmt.Println(re.ReplaceAllString(str, substitution))
}