re = /|author/
str = '{{cite web|url=http://example.com|author=Ninguém}}
{{cite web|url=http://example.com|author=Alguém}}'
subst = '\\|autor'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result