using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((^(\\\\).*)$)|((^[a-z]|[A-Z])[:][\\].*)$";
string input = @"\\mainnt\common\public common\bdelamater
C:\asdasdasd\asdasd
c:\asdklajsdlkajsd
0:\abc
ancC:\lkasjdlkajsd
asdasd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}