$re = '/(?<=\/running\/)(?<processtype>pre-process|process)\/(?<tracker>[1|2])/m';
$str = '/running/pre-process/1
/running/process/1/lorem
/running/pre-process/2
/running/process/2/lorem
/running/pre-process/2
/running/process/2/lorem?ipsum=123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);