package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(^[a-z]{1,3}([0-9]{1,4}\,|[0-9]{1,4})?)`)
var str = `aaa1234,aaa1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}