$re = '/(^[a-z]{1,3}([0-9]{1,4}\,|[0-9]{1,4})?)/i';
$str = 'aaa1234,aaa1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);