$re = '/(?<=Address:\n\n)[a-zA-Z\d\'-,\s]*(?=\n\n)/';
$str = 'Billing Address:
Harry Smith
3423 My Lane
SOME CITY, CA 94105
United States
Some more text';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);