import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(Test|Sample)(?!.*(Hello|World))(?=$|.*(Stuff|Other)).*";
final String string = "Test\n"
+ "Test Good\n"
+ "Sample Stuff \n"
+ "Test Hello \n"
+ "Sample World \n"
+ "Test Hello Stuff \n"
+ "Sample Good World\n"
+ "Test Other\n"
+ "Test Other Stuff \n"
+ "Sample Other World\n"
+ "Test Other Stuff Other\n"
+ "The following strings would be";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}