const regex = /^(Test|Sample)(?!.*(Hello|World))(?=$|.*(Stuff|Other)).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(Test|Sample)(?!.*(Hello|World))(?=$|.*(Stuff|Other)).*', 'gm')
const str = `Test
Test Good
Sample Stuff
Test Hello
Sample World
Test Hello Stuff
Sample Good World
Test Other
Test Other Stuff
Sample Other World
Test Other Stuff Other
The following strings would be`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}