$re = '/\b(?!Bean|Entity)([a-zA-Z]*)Manager\b/';
$str = 'This works nice, but BeanManager and EntityManager are also included Manager AnyManager ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);