#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[(?:\[|\[[^\]]*\|)([^\]\|]+)\]\]"
Local $sString = "This is a note linked to [[Note-2 |another note]] and maybe [[Note1]] "
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)