$re = '/^Q(?=.*[A-Z])(?=.*\d)[A-Z\d]{7}$/m';
$str = 'QC1589ZH
Q1234567
QUANTITY
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);