// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"def\s+(\w+)\((\w+),\s*(\w+)\):").unwrap();
let string = "def wrloc(imm_value, imm_address):";
let substitution = ".macro \\1_imm \\2 \\3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}