using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\S]*(\w*)(?:\s*)(?:\s*\([^()]*\)\S*)*";
string substitution = @"$1*";
string input = @"John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada) James John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada) James";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}