use strict;
my $str = 'John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada) James John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada) James';
my $regex = qr/[^\S]*(\w*)(?:\s*)(?:\s*\([^()]*\)\S*)*/mp;
my $subst = '$1*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";