import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td[^>]*\\bstyle=\"[^\"]*;\\K(?=[^\"]*\">In order to stop receiving)";
final String string = "<tr>\n"
+ "<td style=\"color:#555555;padding-top: 3px;padding-bottom: 20px;\">In order to stop receiving similar emails, simply remove the relevant <a href=\"https://domain.tld/dashboard/?module=saved-searches\" target=\"_blank\">saved search</a> from your account.</td>\n"
+ "</tr>";
final String subst = "font-size: 80%;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}