# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\\\u([^_]+)/\\$$1/g;t' <<< "Jos\\u00e9_A\\u002e_Santos
"