package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\\\\u([^_]+)`)
var str = `Jos\\u00e9_A\\u002e_Santos
`
var substitution = "\\$$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}