package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<\/a>)([^>]*?)(\[\/caption\])`)
var str = `<a href="some/link">link 1</a><p>some really long description</p><a href="another/link">link 2</a>CAPTION TEXT HERE[/caption]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}