import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.*\\/home\\/virtfs.*$)|(^.*\\/net\\/dba.*$)\n";
final String string = "/home/virtfs/lingfieldmeth/etc/alternatives\n"
+ "/home/software/cfs\n"
+ "/home/virtfs/lingfieldmeth/etc/mail\n"
+ "/run/user/1005\n"
+ "/etc\n"
+ "/var/log\n"
+ "/usr/local\n"
+ "/net/dba/cats\n"
+ "/net/dbb/dogs\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}