$re = '/(^.*\/home\/virtfs.*$)|(^.*\/net\/dba.*$)
/m';
$str = '/home/virtfs/lingfieldmeth/etc/alternatives
/home/software/cfs
/home/virtfs/lingfieldmeth/etc/mail
/run/user/1005
/etc
/var/log
/usr/local
/net/dba/cats
/net/dbb/dogs
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);