// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^.*\/home\/virtfs.*$)|(^.*\/net\/dba.*$)
").unwrap();
let string = "/home/virtfs/lingfieldmeth/etc/alternatives
/home/software/cfs
/home/virtfs/lingfieldmeth/etc/mail
/run/user/1005
/etc
/var/log
/usr/local
/net/dba/cats
/net/dbb/dogs
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}