import Foundation
let pattern = #"""
(^.*\/home\/virtfs.*$)|(^.*\/net\/dba.*$)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/home/virtfs/lingfieldmeth/etc/alternatives
/home/software/cfs
/home/virtfs/lingfieldmeth/etc/mail
/run/user/1005
/etc
/var/log
/usr/local
/net/dba/cats
/net/dbb/dogs
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)