// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"/api/documentDownload/(.*)$").unwrap();
let string = "/inga-rest/wallet/aaa
/inga-rest/wallet/MA503122/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA471075/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA471420/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/YYI9878/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA510926/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA299306/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA515464/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA473773/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA515578/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA215692/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA468301/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MV974901/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA486190/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA525372/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA470176/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA281510/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA464449/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA472241/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA482703/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA468533/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA459862/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA501495/products?workflow=CERTIFIED_IDENTITY
/inga-rest/wallet/MA162619/products?workflow=CERTIFIED_IDENTITY";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}