// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*\s-s?n\s*(.+?)(?:\s-.*|$)").unwrap();
let string = "msqlsum81pv 0 0 25 25 25 2 -sn D:\\\\workdir\\\\PV 81\\\\config\\\\sum81pv.pwf -C 5000";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}