$re = '/^(\/\w+\h"[^"]+"\h*)/';
$str = '/ErrorStdOut "C:\\Users\\guinness\\Desktop\\Test.au3" ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);