const regex = new RegExp('^/csr_and_sustainability_information/([^i\\n]|i(i|f(i|r(i|a(i|mi))))*([^fi]|f([^ir]|r([^ai]|a([^im]|m[^ei])))))*(i(i|f(i|r(i|a(i|mi))))*(f(r?|ram?))?)?$', 'gm')
const str = `/csr_and_sustainability_information/blahblah/blah/blah-iframe-asd
/csr_and_sustainability_information/blahblah/blah/blah-
/csr_and_sustainability_information/blahblah/blah/blah-
/csr_and_sustainability_information/blahblah-iframe-blah/blah/blah-asdhaud/iframe`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}