re = /\(\?(?:P<|<|')([^>']+)[>']([^\)]*(\))?\??)\)/
str = '(?P<id>([^\\/:<>\\*\\?"\\|]+(?:\\/[^\\/:<>\\*\\?"\\|]+)?)[\\/\\w-]+)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end