#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\.[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*"
Local $sString = "https://client-eastwood-hue-prod-us.appspot.com.com.som.test/test/"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)