using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*\.?[[:alnum:]]*";
string substitution = @"";
string input = @"https://client-eastwood-hue-prod-us.appspot.com.com.som.test/test/";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}