re = /[#.]?[^{}]*{[^{}]*[{}][^{}]*}(*SKIP)(*F)|[#.]?[^{}]*{([^{}]+)}/
str = '{amdnia91(+wowa}
{amdn{ia91(+wowa}
.something{property:value;prop2:value}#something2{someprop:val;prop:val}
.something{property:value{;prop2:value}#something2{someprop:val;prop:val}
.something{property:v}alue;prop2:value}#something2{someprop:val;prop:val}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end