import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[a-zA-Z])([\\d]+)(?=[a-zA-Z])(?=(?:[^~]*~[^~]*~[^~]*)*$)";
final String string = "5n7x Jahalducro) ~P4J99UMH9~ (MD) auntud C D T)";
final String subst = " $1 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}