use strict;
my $str = '# Validar contraseñas.
# Comprueba que la contraseña tiene más de 6 caracteres.
# Comprueba que la contraseña tiene como mínimo 2 números.
# Comprueba que la contraseña tiene un caracter en mayuscula.
# Contraseñas válidas
4Buhos3programando
prueba21Pass
# Contraseña no válidas
# No tiene mayusculas
contraseña22
# No tiene números
Contraseña.
# Es demasiado corta
33A22
';
my $regex = qr/^(?=.{6,20})(?=(?:.*\d){2,})(?=.*[A-Z]+).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}