import re
regex = re.compile(r"^(?=.{6,20})(?=(?:.*\d){2,})(?=.*[A-Z]+).*$", flags=re.MULTILINE)
test_str = ("# Validar contraseñas.\n"
"# Comprueba que la contraseña tiene más de 6 caracteres.\n"
"# Comprueba que la contraseña tiene como mínimo 2 números.\n"
"# Comprueba que la contraseña tiene un caracter en mayuscula.\n\n"
"# Contraseñas válidas\n"
"4Buhos3programando\n"
"prueba21Pass\n\n"
"# Contraseña no válidas\n\n"
"# No tiene mayusculas\n"
"contraseña22\n"
"# No tiene números\n"
"Contraseña.\n"
"# Es demasiado corta\n"
"33A22\n\n\n\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")