import Foundation
let pattern = #"^(?=.{6,20})(?=(?:.*\d){2,})(?=.*[A-Z]+).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# Validar contraseñas.
# Comprueba que la contraseña tiene más de 6 caracteres.
# Comprueba que la contraseña tiene como mínimo 2 números.
# Comprueba que la contraseña tiene un caracter en mayuscula.
# Contraseñas válidas
4Buhos3programando
prueba21Pass
# Contraseña no válidas
# No tiene mayusculas
contraseña22
# No tiene números
Contraseña.
# Es demasiado corta
33A22
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)