const regex = /=\{([^{}]+)\}(?![^@]*[^=@]{)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('=\\{([^{}]+)\\}(?![^@]*[^=@]{)', 'g')
const str = `singleline:
Year: ={year}</p><p>Director: ={director}<ul>@{ins}<p>inside1: ={in1}</p><p>in2: ={in2}</p>{ins}</ul>
Multiline:
Year: ={year}</p><p>Director: ={director}
<ul>@{actors}<li class="#{class}">={actor}</li><li class="#{class}">={actor}</li>{actors}</ul>\\`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}