$re = '/=\{([^{}]+)\}(?![^@]*[^=@]{)/';
$str = 'singleline:
Year: ={year}</p><p>Director: ={director}<ul>@{ins}<p>inside1: ={in1}</p><p>in2: ={in2}</p>{ins}</ul>
Multiline:
Year: ={year}</p><p>Director: ={director}
<ul>@{actors}<li class="#{class}">={actor}</li><li class="#{class}">={actor}</li>{actors}</ul>\\';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);