using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([^>\s]+)[^>]*>(?:\s*(?:br \/>| | | | | | | | )\s*)*<\/\1>";
string substitution = @"";
string input = @"<td><img width=""100%"" style=""padding-bottom: 5px;"" src=""http://portalvhdsy6f8km33yt638.blob.core.windows.net/mediacontainer/20150827-GLC-header.gif"" alt="" /></td><b > </b>
<br />
<b> </b>
<p></p>
<td><br /></td>
<td></td>
CLEARLY CONFUSED HERE:
<b><br /></b>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}