use strict;
my $str = '<td><img width="100%" style="padding-bottom: 5px;" src="http://portalvhdsy6f8km33yt638.blob.core.windows.net/mediacontainer/20150827-GLC-header.gif" alt="" /></td><b > </b>
<br />
<b> </b>
<p></p>
<td><br /></td>
<td></td>
CLEARLY CONFUSED HERE:
<b><br /></b>';
my $regex = qr/<([^>\s]+)[^>]*>(?:\s*(?:br \/>| | | | | | | | )\s*)*<\/\1>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";