# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<([^>\s]+)[^>]*>(?:\s*(?:br \/>| | | | | | | | )\s*)*<\/\1>"
test_str = ("<td><img width=\"100%\" style=\"padding-bottom: 5px;\" src=\"http://portalvhdsy6f8km33yt638.blob.core.windows.net/mediacontainer/20150827-GLC-header.gif\" alt=\"\" /></td><b > </b>\n\n"
"<br />\n"
"<b> </b>\n"
"<p></p>\n"
"<td><br /></td>\n"
"<td></td>\n\n\n"
"CLEARLY CONFUSED HERE:\n"
"<b><br /></b>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.