const regex = /("([^"]|\\")*[^\\]"|"")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('("([^"]|\\\\")*[^\\\\]"|"")', 'g')
const str = `"hello" world "this " is a t"Es"t
"how did it go?" "" jelly"h\\nllo" "hello\\"
I want you to match a ' [some stuff] then another '
But the last ' can't be preceded by a \\
"this is my super sketchy string"
'-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}