using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\u0080-\uFFFF\w.-](?:[\u0080-\uFFFF\w. -]*[\u0080-\uFFFF\w.-])?$";
string input = @"àèéìòóùàbfgbhfĞ ğ Ş ş İ ı ą ć ę ł ń ó ś ź ż Ż Ź Ś Ó Ń Ł Ę Ć Ą";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}