const regex = /^[\u0080-\uFFFF\w.-](?:[\u0080-\uFFFF\w. -]*[\u0080-\uFFFF\w.-])?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\u0080-\\uFFFF\\w.-](?:[\\u0080-\\uFFFF\\w. -]*[\\u0080-\\uFFFF\\w.-])?$', '')
const str = `àèéìòóùàbfgbhfĞ ğ Ş ş İ ı ą ć ę ł ń ó ś ź ż Ż Ź Ś Ó Ń Ł Ę Ć Ą`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}